AminetAminet
Search:
83367 packages online
About
Recent
Browse
Search
Upload
Setup
Services

driver/media/AtapiMagic.lha

Mirror:Random
Showing:m68k-amigaosppc-amigaosppc-morphosi386-arosi386-amithlonppc-warpupppc-powerupgeneric
No screenshot available
Short:Use 4 way IDE devices
Author:info at hyperion-entertainment.com (Hyperion Entertainment CVBA)
Uploader:ignaciogully gmail com (Ignacio F. Gully)
Type:driver/media
Version:47.1
Requires:OS 3.1.4 or better recommended.
Architecture:m68k-amigaos
Date:2020-10-29
Download:http://aminet.net/driver/media/AtapiMagic.lha - View contents
Readme:http://aminet.net/driver/media/AtapiMagic.readme
Downloads:503

                    AtapiMagic 47.1 

AtapiMagic 47.1 and accesory (hereinafter "Files" or "Archive") and 
their related documentation, and examples are:

Copyright (c) 2019-2020 Hyperion Entertainment CVBA.
All Rights Reserved

These Files and their related documentation and examples are provided 
"AS-IS" and subject to change without notice; no warranties are made. 
All use is at your own risk. No liability or responsibility nor 
support is assumed.


A. DISTRIBUTION OF THE ATAPIMAGIC ARCHIVE

The complete and ATAPIMAGIC archive, as provided by 
Copyright (c) 2019-2020 Hyperion Entertainment CVBA., may not be 
redistributed or modified via any means. The Archive may not be sold 
individually or distributed in conjunction with any other product.


B. USAGE

AmigaOS always supported 2 devices on the IDE port. To be able to 
use 4, a third party software patch called IDEFix was often used. The 
problem is that the IDEFix software does not work correctly under many 
OS versions. In fact, on many scenarios, it will most likely fail.

AtapiMagic has been tested working under both AmigaOS 3.1.4 and 
AmigaOS 3.2. That said, under a few unknown circumstances, it seems it 
may not work according to a small amount of reports received.

Please remember that no support will be provided other than what is 
included in this archive. So if it does not work for you tough luck, 
but if it does then great!

Unarchive AtapiMagic, and place it in LIBS:modules. 

To be able to use it, just open your Startup-sequence with a text 
editor where you will find:

If Exists C:LoadModule
   C:Version exec.library version 46 >NIL:
   If Warn
      C:LoadModule ROMUPDATE
   EndIf
EndIf

Just modify those six lines with the following ones:

If Exists C:LoadModule
   C:Version exec.library version 46 >NIL:
   If Warn
      C:LoadModule LIBS:modules/AtapiMagic ROMUPDATE
   Else
      C:LoadModule LIBS:modules/AtapiMagic
   EndIf
EndIf

Save the Startup-Sequence and reboot your machine for the changes to 
take effect.

If everything went fine, you should now be able to use 4 IDE 
interfaces without the need of any third party software.

Important: If you are using AmigaOS 3.2 just simply replace the 46 
number version on the example above with 47.


C. ACKNOWLEDGEMENTS

Thanks to Hyperion Entertainment CVBA for being kind enough to give me
an authorization to distribute this alpha state component. 

All Trademarks are copyright of their respective owners.

Ignacio F. Gully - 29.10.2020


Contents of driver/media/AtapiMagic.lha
PERMISSION  UID  GID    PACKED    SIZE  RATIO METHOD CRC     STAMP     NAME
---------- ----------- ------- ------- ------ ---------- ------------ ----------
[unknown]                 1361    2788  48.8% -lh5- a11c Oct 29 23:48 AtapiMagic.readme
[unknown]                  132     172  76.7% -lh5- 6e4d Dec 20  2019 AtapiMagic
---------- ----------- ------- ------- ------ ---------- ------------ ----------
 Total         2 files    1493    2960  50.4%            Oct 30 03:26

Aminet © 1992-2021 Urban Müller and the Aminet team. Aminet contact address: <aminetaminet net>